BETA

14th October 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [14/10/17 11:34 AM] with 'Partial Outage'

Issue has been resolved at [14/10/17 02:49 PM]