BETA

14th October 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/10/17 11:24 AM] with 'Major Outage'

Issue has been resolved at [14/10/17 11:25 AM]