BETA

14th October 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [14/10/17 11:13 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/10/17 01:49 PM]