BETA

13th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [13/03/19 04:46 AM] with 'Partial Outage'

Issue has been resolved at [13/03/19 04:47 AM]