BETA

14th October 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/10/17 08:50 AM] with 'Partial Outage'

Issue has been resolved at [14/10/17 08:51 AM]