BETA

14th October 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/10/17 08:50 AM] with 'Major Outage'

Issue has been resolved at [14/10/17 08:51 AM]