BETA

6th September 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [06/09/16 02:07 AM] with 'Partial Outage'

Issue has been resolved at [06/09/16 02:11 AM]