BETA

13th October 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/10/17 07:28 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/10/17 07:54 PM]