BETA

13th October 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/10/17 06:46 PM] with 'Major Outage'

Issue has been resolved at [13/10/17 06:47 PM]