BETA

13th October 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [13/10/17 04:27 PM] with 'Partial Outage'

Issue has been resolved at [13/10/17 04:29 PM]