BETA

13th October 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/10/17 04:23 PM] with 'Major Outage'

Issue has been resolved at [13/10/17 04:24 PM]