BETA

5th September 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [05/09/16 01:15 PM] with 'Major Outage'

Issue has been resolved at [05/09/16 01:38 PM]