Exotel Status Board
Home
Dashboard
BETA
29th April 2025
Mumbai
Issue observed for 'Outgoing Calls' in Mumbai Region
Identified at [29/04/25 09:55 PM] with 'Major Outage'
Issue has been resolved at [29/04/25 10:07 PM]