Exotel Status Board
Home
Dashboard
BETA
23rd April 2025
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [23/04/25 12:25 PM] with 'Major Outage'
Issue has been resolved at [23/04/25 12:35 PM]