BETA

9th April 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [09/04/25 04:40 PM] with 'Major Outage'

Issue has been resolved at [09/04/25 04:52 PM]