Exotel Status Board
Home
Dashboard
BETA
4th April 2025
Kerala
Issue observed for 'Outgoing Calls' in Kerala Region
Identified at [04/04/25 06:30 AM] with 'Major Outage'
Issue has been resolved at [04/04/25 07:28 AM]