BETA

4th April 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [04/04/25 04:55 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [04/04/25 06:28 AM]