Exotel Status Board
Home
Dashboard
BETA
30th March 2025
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [30/03/25 11:50 AM] with 'Major Outage'
Issue has been resolved at [30/03/25 11:55 AM]