BETA

30th March 2025

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [30/03/25 10:37 AM] with 'Partial Outage'

Issue has been resolved at [30/03/25 10:50 AM]