BETA

5th September 2016

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [05/09/16 01:12 PM] with 'Partial Outage'

Issue has been resolved at [05/09/16 01:38 PM]