BETA

24th March 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [24/03/25 01:47 PM] with 'Partial Outage'

Issue has been resolved at [24/03/25 02:00 PM]