BETA

21st March 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [21/03/25 12:07 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/03/25 12:30 PM]