Exotel Status Board
Home
Dashboard
BETA
18th March 2025
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [18/03/25 08:15 AM] with 'Major Outage'
Issue has been resolved at [18/03/25 08:20 AM]