BETA

10th March 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [10/03/25 10:35 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [10/03/25 10:57 AM]