BETA

8th March 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [08/03/25 10:00 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [08/03/25 10:22 AM]