BETA

3rd March 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [03/03/25 09:55 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/03/25 10:12 AM]