BETA

13th October 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/10/17 02:34 PM] with 'Partial Outage'

Issue has been resolved at [13/10/17 02:35 PM]