BETA

1st March 2025

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [01/03/25 12:40 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [01/03/25 02:17 AM]