Exotel Status Board
Home
Dashboard
BETA
24th February 2025
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [24/02/25 04:15 AM] with 'Major Outage'
Issue has been resolved at [24/02/25 04:30 AM]