BETA

23rd February 2025

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [23/02/25 01:45 PM] with 'Partial Outage'

Issue has been resolved at [23/02/25 02:05 PM]