BETA

20th February 2025

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [20/02/25 12:35 PM] with 'Partial Outage'

Issue has been resolved at [20/02/25 12:47 PM]