BETA

19th February 2025

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [19/02/25 04:37 PM] with 'Partial Outage'

Issue has been resolved at [19/02/25 04:45 PM]