Exotel Status Board
Home
Dashboard
BETA
18th February 2025
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [18/02/25 10:00 PM] with 'Major Outage'
Issue has been resolved at [18/02/25 10:05 PM]