BETA

8th February 2025

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [08/02/25 04:37 PM] with 'Partial Outage'

Issue has been resolved at [08/02/25 04:45 PM]