BETA

6th February 2025

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [06/02/25 05:05 PM] with 'Partial Outage'

Issue has been resolved at [06/02/25 05:25 PM]