BETA

1st February 2025

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [01/02/25 05:30 AM] with 'Partial Outage'

Issue has been resolved at [01/02/25 05:35 AM]