Exotel Status Board
Home
Dashboard
BETA
29th January 2025
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [29/01/25 11:05 AM] with 'Major Outage'
Issue has been resolved at [29/01/25 11:27 AM]