Exotel Status Board
Home
Dashboard
BETA
28th January 2025
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [28/01/25 12:00 PM] with 'Major Outage'
Issue has been resolved at [28/01/25 03:00 PM]