Exotel Status Board
Home
Dashboard
BETA
14th January 2025
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [14/01/25 03:45 PM] with 'Major Outage'
Issue has been resolved at [14/01/25 04:55 PM]