Exotel Status Board
Home
Dashboard
BETA
14th January 2025
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [14/01/25 08:35 AM] with 'Major Outage'
Issue has been resolved at [14/01/25 10:25 AM]