BETA

13th October 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [13/10/17 01:02 PM] with 'Partial Outage'

Issue has been resolved at [13/10/17 01:03 PM]