BETA

11th January 2025

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [11/01/25 11:10 PM] with 'Partial Outage'

Issue has been resolved at [11/01/25 11:35 PM]