Exotel Status Board
Home
Dashboard
BETA
31st December 2024
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [31/12/24 09:32 PM] with 'Major Outage'
Issue has been resolved at [31/12/24 09:40 PM]