BETA

25th December 2024

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [25/12/24 09:05 PM] with 'Partial Outage'

Issue has been resolved at [25/12/24 09:20 PM]