BETA

13th October 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/10/17 10:08 AM] with 'Major Outage'

Issue has been resolved at [13/10/17 10:09 AM]