Exotel Status Board
Home
Dashboard
BETA
27th October 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [27/10/24 02:45 AM] with 'Major Outage'
Issue has been resolved at [27/10/24 03:15 AM]