BETA

13th October 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/10/17 06:10 AM] with 'Major Outage'

Issue has been resolved at [13/10/17 06:11 AM]