BETA

14th October 2024

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [14/10/24 03:05 AM] with 'Partial Outage'

Issue has been resolved at [14/10/24 03:15 AM]