BETA

12th October 2024

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [12/10/24 11:40 AM] with 'Partial Outage'

Issue has been resolved at [12/10/24 11:45 AM]