Exotel Status Board
Home
Dashboard
BETA
10th October 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [10/10/24 12:25 PM] with 'Major Outage'
Issue has been resolved at [10/10/24 12:43 PM]